Progress Bar Inspector (ex. Ctls issues)

Buttons, Arrows, Sets, Sliders, RealField and UnitField: http://zinnamturm.eu/downloadsAC.htm#Ctls

Progress Bar Inspector (ex. Ctls issues)

Postby dmaksimiuk » Wed Feb 21, 2018 11:09 am

Hi,
I have moved to the latest stable release of the framework (1.7.1 /1014). I have installed the Ctls component. I have observed that after adding a progress bar into my application (or even inserting it anywhere), I cannot change its properties using properties inspector. It does not start "Progress Bar Inspector" (no error message, no complains from the system). Also inserted sliders are just grey vertical bars.

I have a bare installation of the framework on my HD, and all subsystems are installed in a different location ( access with the '/USE Path' option).
I am running Win7 Pro (also have the same behaviour on another machine with Win10 Pro).

The "Progress Bar Inspector" works well on one of my old version of the framework (1.7.1-a1 / b480) where all subsystems are installed in the same directory with the framework.

Any idea how to fix it? Can I chance properties of the progresses bar from my program?

Regards,
Darek

P.S. Another issue is with the latest M$ Security Essential (with virus/spyware def file #:1.261.1428.0). It says that the BBox installation file (blackbox-1.7.1-setup.exe
) contains the Tiggre!rfn trojan.
dmaksimiuk
 
Posts: 28
Joined: Sun Jun 14, 2015 3:56 pm
Location: Delft, The Netherlands

Re: Ctls issues

Postby Josef Templ » Wed Feb 21, 2018 1:20 pm

dmaksimiuk wrote:Hi,
I have moved to the latest stable release of the framework (1.7.1 /1014). I have installed the Ctls component. I have observed that after adding a progress bar into my application (or even inserting it anywhere), I cannot change its properties using properties inspector. It does not start "Progress Bar Inspector" (no error message, no complains from the system). Also inserted sliders are just grey vertical bars.

I have a bare installation of the framework on my HD, and all subsystems are installed in a different location ( access with the '/USE Path' option).
I am running Win7 Pro (also have the same behaviour on another machine with Win10 Pro).

The "Progress Bar Inspector" works well on one of my old version of the framework (1.7.1-a1 / b480) where all subsystems are installed in the same directory with the framework.

Any idea how to fix it? Can I chance properties of the progresses bar from my program?

Regards,
Darek

P.S. Another issue is with the latest M$ Security Essential (with virus/spyware def file #:1.261.1428.0). It says that the BBox installation file (blackbox-1.7.1-setup.exe
) contains the Tiggre!rfn trojan.



For CtlsProgress.Control there seems to be a missing entry in the Ctls/Rsrc/Strings.odc file.
Add a line like this:

Progress.Property StdCmds.OpenToolDialog ('Ctls/Rsrc/ProgressInspector', 'Progress-Bar Inspector')

As far as I understand it, it is an issue that needs to be fixed in the Ctls subsystem, not in the BlackBox distribution.

- Josef
Josef Templ
 
Posts: 194
Joined: Tue Sep 17, 2013 6:50 am

Re: Ctls issues

Postby Zinn » Sat Feb 24, 2018 3:14 pm

Thank you for the solution. I upload the correction of Ctls to CPC.
- Helmut
Zinn
 
Posts: 58
Joined: Mon Nov 24, 2014 10:47 am

Re: Progress Bar Inspector (ex. Ctls issues)

Postby Josef Templ » Mon Feb 26, 2018 10:58 am

Please also check if there are other such lines missing.

- Josef
Josef Templ
 
Posts: 194
Joined: Tue Sep 17, 2013 6:50 am


Return to Ctls

Who is online

Users browsing this forum: No registered users and 1 guest

cron