Page 1 of 1

Compatibility with version 1.7

PostPosted: Fri Sep 09, 2016 4:21 pm
by Robert
The license for the subsystem Lib starts:
Educational License
This subsystem may be used for non-commercial educational and personal purposes. This subsystem may be used with the Educational and Shareware editions of BlackBox 1.4.


Since, I expect, most people will assume that components on the CPC site are compatible with the current versions of BlackBox I have requested that this sub system be removed when the stable "Centre" release of BlackBox 1.7 is available - which I think will be very soon now.

I do not think there are still many users of BlackBox 1.4, and even fewer who will want to down-load this subsystem in the future, not having down-loaded it in the last 10 years.


As a consequence several other CPC subsystems also need to be withdrawn as they rely on importing Lib.

Re: Compatibility with version 1.7

PostPosted: Wed Sep 14, 2016 8:51 am
by Zinn
Here is the subsystem Lib downloads statistic of the last 10 years:

2008 669 (Top 5)
2009 561 (Top 5)
2010 197 (Top 5)
2011 199 (Top 5)
2012 082 (Top 10)
2013 065 (Top 10)
2014 076
2015 156 (Top 5)
2016 091

Removing subsystem Lib means to remove also Algebra, Casket, Chill, Filter, Multi, Nav, OglChill and Wands.
Removing subsystem Lib breaks subsystem Epse21.

-Helmut

Re: Compatibility with version 1.7

PostPosted: Mon Dec 19, 2016 11:01 pm
by Robert
An updated version of Lib that is compatible with BlackBox 1.7 has been published on CPC.

Re: Compatibility with version 1.7

PostPosted: Fri Jul 28, 2017 7:53 pm
by Robert
Robert wrote:An updated version of Lib that is compatible with BlackBox 1.7 has been published on CPC.

This does not seem to be entirely correct!

(I think!) that Lib is not (fully) compatible with the "Stable" version of 1.7, but it requires build 845 (10-April-2017) or later.
I suggest using the version "Alpha version 1.7.1-a1" from: http://blackboxframework.org/index.php? ... page,en-us