Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

All except GUI problems

Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby rolling_thunder » Thu Nov 28, 2019 3:40 pm

Hello,

I am having issues with integrating BlackBox v1.6 with OPENBUGS despite following the instructions provided under: http://www.openbugs.net/Manuals/Developer/Tools.html

The error message given is: Kernel.Hook^: wrong fingerprint (imported from Dialog)
which I haven't found any solutions to on google.

I have tested this across two other systems to no avail, the same , this version of BlackBox was obtained from: http://www.oberon.ch/blackbox.html

[EDIT] I have been looking through the STDloader module to see what the error means but it's way over my head: http://oberspace.org/WeBB//Std/Mod/Loader.html

Thank you for your time,
RT
rolling_thunder
 
Posts: 3
Joined: Thu Nov 28, 2019 3:23 pm

Re: Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby Josef Templ » Thu Nov 28, 2019 5:20 pm

it seems that you are loading incompatible versions of some modules.
If you have the sources, recompile them all.

BlackBox 1.6 is a pretty old version, by the way, but it is the latest from oberon microsystems.
Newer versions are available from the BlackBox Framework Center at http://blackboxframework.org/index.php?cID=goto-download-page,en-us.
However, I don't know if there is anything in OpenBUGS that needs BlackBox 1.6,

- Josef
Josef Templ
 
Posts: 242
Joined: Tue Sep 17, 2013 6:50 am

Re: Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby Ivan Denisov » Thu Nov 28, 2019 5:36 pm

Where did you take sources?
It seems, that the link https://openbugs.svn.sourceforge.net/svnroot/openbugs is broken.

Do you know about new project?
https://github.com/MultiBUGS/MultiBUGS
User avatar
Ivan Denisov
 
Posts: 277
Joined: Tue Sep 17, 2013 12:21 am
Location: Krasnoyarsk, Russia

Re: Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby rolling_thunder » Thu Nov 28, 2019 6:35 pm

Hello,

Thank you for the helpful responses! The OpenBUGS source is as follows: http://www.openbugs.net/w/Downloads

OpenBUGS had an update in 2015 (or so), if the module versions are the issue, then perhaps the documentation may be outdated (I believe it was last updated/written in 2010)-- i.e. the WBDev documentation refers to BlackBox v1.6.

I have tried newer versions of BlackBox as well without much luck; but I'll also give MultiBUGS a shot.

However, if that doesn't fall through, how does one go about recompiling modules? Thank you.

[EDIT] I tried the integration of BlackBox with MultiBUGS, the steps outlined in the documentation works, but BlackBox cannot run MPIworker.odc when attempting to run MultiBUG's "Make.odc" to link MultiBUGS and BlackBox modules.
rolling_thunder
 
Posts: 3
Joined: Thu Nov 28, 2019 3:23 pm

Re: Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby luowy » Fri Nov 29, 2019 7:34 am

rolling_thunder wrote:However, if that doesn't fall through, how does one go about recompiling modules?

I have checked the problem, there is no "Kernel" source File in Openbugs setup directory, so your have to recompile the openbugs source under the BB1.6! the step:
1, select all files&directories under Openbugs;
2, paste all into BB1.6 directory,and skip all same name files;
3, run balckbox.exe, Open Std/Mod/Cmd1.odc , and compile it(ctr+k),
then open the Developer/Manual.odc , follow it's instrutions, compile and link ...
(if compile error occur, replace the origin module of BB1.6 with the same name module in Openbugs dir )
4, then in the bb1.6 directory, the openbugs.exe is new and workable;

I have successfully build it; If you have trouble building it,I can send the zip file to you


luowy
luowy
 
Posts: 51
Joined: Thu Dec 17, 2015 1:32 pm

Re: Issue with BlackBox v1.6 + OPENBUGS integration on WIN10

Postby rolling_thunder » Sun Dec 08, 2019 6:23 pm

luowy wrote:
rolling_thunder wrote:However, if that doesn't fall through, how does one go about recompiling modules?

I have checked the problem, there is no "Kernel" source File in Openbugs setup directory, so your have to recompile the openbugs source under the BB1.6! the step:
1, select all files&directories under Openbugs;
2, paste all into BB1.6 directory,and skip all same name files;
3, run balckbox.exe, Open Std/Mod/Cmd1.odc , and compile it(ctr+k),
then open the Developer/Manual.odc , follow it's instrutions, compile and link ...
(if compile error occur, replace the origin module of BB1.6 with the same name module in Openbugs dir )
4, then in the bb1.6 directory, the openbugs.exe is new and workable;

I have successfully build it; If you have trouble building it,I can send the zip file to you


luowy


louwy,

Sorry for the late reply, and thanks for looking into the issue!
Unfortunately while BB1.6 was compiling the source code using make.ode (at step 3), it came up with a "missing identifier" error in (BUGS)Cmds.odc that I'm not sure how to deal with.

If you can PM the rebuilt OpenBUGS files, that would be great!
Best,
RT
rolling_thunder
 
Posts: 3
Joined: Thu Nov 28, 2019 3:23 pm


Return to BlackBox Framework

Who is online

Users browsing this forum: No registered users and 1 guest

cron